PHP Updates: PHP 5.5.11 & 5.4.27

PHP

 

We are pleased to announce that we have completed an update of the PHP versions available on all shared and business cloud servers to PHP versions 5.5.11 and 5.4.27. These updates contain several bug fixes as well as a security update to address CVE-2013-7345, for more details please see the PHP.net change log notes for PHP 5.5.11 and 5.4.27.

The use of PHP 5.5 and 5.4 can be enabled on your account or on a per-directory basis through a simple .htaccess modification. This modification can be placed in an accounts public_html/.htaccess file to enable PHP 5.5 or 5.4 for the entire account or in the .htaccess file of a specific directory (e.g: public_html/wordpress/.htaccess) to enable under that directory tree only.

To enable PHP 5.5 or 5.4, you must add one of the following htaccess option:

 AddType application/x-httpd-php55 .php

Or

 AddType application/x-httpd-php54 .php

The binary path to the PHP 5.5 and 5.4 installations, should you require it for executable php scripts or cronjobs, is located at:

/usr/local/php55/bin/php

And

/usr/local/php54/bin/php

As with the existing PHP 5.3 setup, when you enable PHP 5.5 or 5.4, it will respect any custom php.ini settings you may have under your account. In addition, all standard PHP modules and extensions from the existing PHP 5.3 setup are default enabled in the PHP 5.5 and 5.4 setup to ensure the best compatibility possible.

As always, questions or comments, we can be reached 24/7 through any of our support channels, thank you.